Browser support

For an optimal experience that offers better performance, accessibility, and security, D2L recommends that all users access Brightspace Learning Environment with the latest version of a supported browser.

Tip: By default, most browsers automatically update to the latest version. To ensure you are running the latest browser version, D2L recommends that you set your browser to auto-update.

When new browser versions are released, D2L is committed to performing key application testing to ensure that Brightspace Learning Environment performs as expected.

Brightspace notifies users when their browser needs updating. This appears on both mobile and desktop devices and encourages users to update their browser but does not change the functionality of Brightspace.

Note the following:

Supported browsers

Supported browsers are the latest browser versions that are tested against Brightspace Learning Environment.

Using the most up-to-date version of a supported browser ensures that you have the best Brightspace experience possible.

You can report problems and receive technical support for issues with supported browsers.

Desktop Computers

Brightspace Learning Environment is supported on the following desktop platforms with the latest browser versions:

Platform

Apple® Safari®

Google® Chrome™ Microsoft® Edge Mozilla® Firefox®
Apple® Mac OS® Yes Yes Yes Yes
Microsoft® Windows® No Yes Yes Yes

Tablets and Mobile Devices

Brightspace Learning Environment is supported on the following tablets and mobile devices with the latest browser versions:

Platform

Apple® Safari®

Google® Chrome™ Microsoft® Edge Mozilla® Firefox®
Apple® iOS® for iPhone® and iPad® Yes No No No
Android™ OS for Android phones and tablets No Yes No No

Retro and legacy browsers

You can access Brightspace Learning Environment with retro or legacy browsers (specific older versions of supported browsers); however, D2L does not test Brightspace Learning Environment against these older versions. This means you may encounter unexpected user interface behavior and appearance, or broken and unsupported functionality.

In most cases, D2L does not provide technical support or fix software defects experienced in retro and legacy browsers.

When there is an announcement that a browser version is becoming retro or legacy, a feature appears in the Brightspace Platform release notes to notify users about the scheduled changes.

If you attempt to connect to a Brightspace instance with an unsupported browser, Brightspace Learning Environment's browser version check displays a retro or legacy browser warning message.

Using a browser below the latest update's threshold prompts the message "Your browser is looking a little retro". The browsers include:

  • Chrome 100+ (released March 2022)

  • macOS Safari 15+ (Released September 2021)

  • Firefox 99+ (released April 2022)

  • Microsoft Edge 100+ (released April 2021)

  • Chrome OS Chrome 100+ (released March 2022)

  • iOS Safari 15+ (released September 2021)

  • Android Chrome 100+ (released March 2022)

If you use a Legacy Browser, you may have difficulty accessing parts of Brightspace if your browser is not up to date. This prompts the message "Unsupported Browser" when logging in. Browsers older than these receive legacy messaging:

  • Chrome 74 (released April 2019)

  • macOS Safari 13 (released September 2019)

  • Firefox 67 (released May 2019)

  • Chrome OS Chrome 74 (released April 2019)

  • iOS Safari 13 (released September 2019)

  • Android Chrome 74 (released April 2019)

Unsupported (blocked) browsers

Unsupported or blocked browsers are browsers that are explicitly blocked by Brightspace Learning Environment, due to extremely low usage, potential security vulnerabilities, or performance issues.

D2L does not provide technical support for unsupported browsers.

When a browser version is classified as an unsupported browser, a feature appears in the Brightspace Platform release notes, notifying users about this change.

If a user attempts to connect to a Brightspace instance with an unsupported browser, an error message displays, preventing them from logging in. Currently, this list includes all versions of Microsoft Internet Explorer and Microsoft Edge Legacy.